Follow us on Facebook and Twitter!

missing comment
#1
Bug 
Hi,

A friend left me a comment on a test page i set up for testing, i received the email saying he left a comment but the comment doesn't show on the page. all the other messages have shown up ok but not this one.. i cant see it in the admin panel and there is only one page i have with commentics on it.  Im still waiting on details from my mate about the device he sent it from etc and if he got any error message or anything. its just strange i got the email but not the comment.

Looking at the email, i noticed cmtx_perm=0#cmtx_perm_0 at the end. the 0's are normally the comment number? also there is a thumb in the comment! what is that?
Code:
Hello,

A new comment has been posted on the page Messages, located at the following address:
http://removed_for security/message.php?cmtx_perm=0#cmtx_perm_0

The comment was made by J-shwaa and was as follows:

************************

This is a testie message... Testie testie tesites ?

************************

This comment does not require approval.

edit: after a little testing i worked out its from the thumb.. what is it? why does it pass the sanitize? and why does it make the id 0? the form says comment sent ok
Reply
#2
i think its this little sucker that brings out the bug..
Unicode Character 'THUMBS UP SIGN' (U+1F44D)
Reply
#3
(04-Oct-2014, 07:28 PM)Hootie81 Wrote: after a little testing i worked out its from the thumb

Can you explain what you mean?
Have you completed the interview?
Reply
#4
One of my mates sent me a comment that had a little thumb in it, (?) the thumb is a UTF8 character, the code is 0xF0 0x9F 0x91 0x8D

He said its something that all iphones can send as a standard feature..

Ive included it in the ( ) above, but it may show up as a ? like in the first post above.
If you go here and copy the little thumb (the smaller icon under the heading java)
http://www.fileformat.info/info/unicode/.../index.htm

and send yourself a comment with it in.. you will get an email but no comment.
Reply
#5
Okay I understand what you mean now, however I get a different result. I submitted this comment with the thumb at the end of the sentence. As you can see, the comment is there and has a normal ID. The thumb appeared fine inside the textarea, when previewing and in the email that I received. The part where it lost it seems to be when inserting into the database. I'm not sure why you had a different result without looking into it further. It might be because I posted it using my web browser by copying it from your link, as opposed to posting directly from an iPhone. I need to do some more testing. Do you think icons like that should be allowed? I believe I've seen them a few times before on sites like Facebook. By the way I choose not to receive comment notification emails (Settings -> Administrator) for the demo so it's hard to verify what happened with your test. I don't have any comments in my database with an ID of 0.
Have you completed the interview?
Reply
#6
Hmm i did my test to get the same result by cut and pasting from that site i showed you into firefox and sent the message, it said sent ok but didnt show up in the database.

When i can get my remote access working again i will check the logs and see if there is anything. is there a log i should check?
Reply
#7
You can try enabling error reporting in the admin panel. More information is here: http://www.commentics.org/support/knowle...article=15
Have you completed the interview?
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Add comment and Preview buttons do not work salesn 2 260 22-Oct-2018, 10:22 PM
Last Post: salesn
  Comment likes dislikes not working muhammad ali 4 848 15-Aug-2017, 09:11 AM
Last Post: muhammad ali
  Comment form not visible sanzuu 9 1,782 19-Mar-2017, 02:52 PM
Last Post: Steven
  Sort By: missing Tom C. 3 1,978 19-Apr-2013, 12:50 PM
Last Post: Steven
  The comment entered has already been submitted. BinaryAccepted 6 3,731 10-Sep-2012, 03:44 PM
Last Post: Steven
  page loads halfway after submitting comment Edgey 2 2,089 24-Aug-2012, 08:40 PM
Last Post: Edgey
  Focus of comment submission lost in between elements jjevans 1 1,428 14-Apr-2012, 09:51 PM
Last Post: Steven
  After comment is edited, links in comment change from absolute to relative. stariocek 2 1,773 05-Mar-2012, 06:43 PM
Last Post: stariocek
  Question missing from Preview mtbroutes 2 1,462 11-Oct-2011, 05:15 PM
Last Post: mtbroutes
  Reserved Name and Recent comment Mr.Know 1 1,390 04-Sep-2011, 03:41 PM
Last Post: Steven

Forum Jump:


Users browsing this thread: 1 Guest(s)