Follow us on Facebook and Twitter!

submitted several comments recently
Whenever I submit a comment regardless of the details placed in the form, I get ..
"You have submitted several comments recently. Please wait longer."
I have changed names and email details and have removed all cookies.
Admin Detection is activated.
Any advice please.
Hi Wendon,

You're right this is a bug. It checks the IP address (which is why it doesn't make any difference when you use a different name or clear your cookies), but the bug is how it ignores that it's the admin. It used to check whether it was the admin in v2.x but I guess this wasn't carried over in v3.x.

To fix open this file:

Find this:
PHP Code:
if ($this->setting->get('flood_control_delay_enabled')) { 

Replace with:
PHP Code:
if ($this->setting->get('flood_control_delay_enabled') && !$is_admin) { 

Find this:
PHP Code:
if ($this->setting->get('flood_control_maximum_enabled')) { 

Replace with:
PHP Code:
if ($this->setting->get('flood_control_maximum_enabled') && !$is_admin) { 
Have you completed the interview?
Thanks Steven, that works a treat...
but now (not sure if it's connected to that problem) when I (Admin) accesses 'Manage/Comments' and edit a comment...
(url: mysite/commentic/adminarea/index.php?route=edit/comment&id=28 ) on hitting the 'update' button I am taken to my sites front page. This is what happens when an unknown location has been entered. The url remains as shown above and no changes have been made to the comment.
Can you PM me your admin login so I can determine what's happening?
Have you completed the interview?
I've tested clicking 'Update' for that particular comment in both Chrome and Firefox and it's working successfully for me.

Are you still able to replicate it? If so, can you try a different browser/computer. Then, if it's still happening, can you send me your browser details using this:
Have you completed the interview?
Hello Steven.
Well, I don't know what to say... I tested it again and it's working fine. Maybe you just frightened it.

Sorry for the trouble and many thanks.

I have been receiving the following message even though I have posted fewer times than the 'Amount' set in flooding. (5 times in a period of 1 hour)

"You have submitted several comments recently. Please wait longer."

This occurs weather or not 'Admin detection' is enabled or disabled. I have also tried posting with an email other than the admin email address.

The only thing that will allow me to post is by keeping the 'Maximum' radio button unchecked.


Hi Neo I committed a fix for this recently. Please apply this change in /frontend/model/main/form.php
Have you completed the interview?
Thanks Steven, works fine now.

Possibly Related Threads…
Thread Author Replies Views Last Post
Exclamation Weird comments section look SPOOKYTHIB 2 197 23-Apr-2019, 04:46 PM
  Comments not showing 2hands 2 526 19-Nov-2017, 12:21 AM
Last Post: 2hands
  Comments Not Refreshing muhammad ali 2 638 22-Aug-2017, 08:33 AM
Last Post: muhammad ali
  Comments Causing HTTPS To Become Insecure Methyus 17 5,229 17-Dec-2016, 05:40 PM
Last Post: Methyus
  Bug in comments.php Deparis 2 1,660 21-Jul-2014, 11:39 AM
Last Post: Deparis
  comments gone? johan 1 1,548 30-Oct-2013, 12:01 AM
Last Post: johan
  Strange symbols above comments (  ) danashton 1 1,786 26-Sep-2013, 06:09 PM
Last Post: Steven
  all comments being banned Jim 2 2,268 16-Sep-2013, 05:09 PM
Last Post: Jim
  Recent Comments: Url Maxlength redirect problem donovanes 2 2,555 31-May-2013, 05:57 PM
Last Post: donovanes
  on Submit comments box dissappear azadatif 1 1,658 16-Jan-2013, 02:53 PM
Last Post: Steven

Forum Jump:

Users browsing this thread: 1 Guest(s)